Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

New profile posts

Gday, I have a small vibration in my VY s2 clubsport from 140 onwards. (only noticed when over taking on the highway)
ive not long purchased the car & have noticed the the tail shaft centre bearing has recently be replaced. I have been told if the tail shaft & diff bolts are not replaced in the same order they were removed, that could be a source of the vibration. Any help would be great
Cheers
Gday, I have a small vibration in my VY s2 clubsport from 140 onwards. (only noticed when over taking on the highway)
ive not long purchased the car & have noticed the the tail shaft centre bearing has recently be replaced. I have been told if the tail shaft & diff bolts are not replaced in the same order they were removed, that could be a source of the vibration. Any help would be great
Cheers
Hey guys why would my low beam lights cut out when I flick to high beam? And would that also be causing my front parkers to not work ? It’s a vz sv6
Hi I have just bought a 2016 s2 Vf sv6 sports wagon, and would like to know how I can get satnav for my mylink
Head unit.
Subju
Subju
Best to use your phone and just setup android auto or apple play.
Hi guys I have a vt commodore v6 auto while its in park I go to rev my car and it’s shuttering on Acceleration and it also does it when I’m drive I’ve replaced fuel pump fuel filter coil packs the spark leads look brand new I’m going to replace the spark plugs and see how it goes
I have just had a dyna tune and some mods done on my VF V6 3 litre Commodore Evoke auto, I want to know if you can help me and my mechanic the problem is when you come to a stop or slow to turn the motor cuts out below 45 kmph. any help wouldbe a appreciated
Top