Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY LS1 to LS3 Troubles

NickGNB

New Member
Joined
Aug 31, 2014
Messages
29
Reaction score
0
Points
1
Location
Sydney-North Shore
Members Ride
VY SS Sedan, VY II Acclaim Wagon, Ford Territory
So my LS3 has arrived to replace my (very) tired LS1. I will use the converter box for the reluctor wheel, sensors etc, and replace the throttle body with a cable (probably Holley) TB.

I had thought that all of the LS1 bolt-ons would fit the LS3 however, and it seems I'm wrong. The LS1 P/S Pump and tensioner pulley both seem to sit about 20mm proud of the LS3s Harmonic Balancer and Water pump. Does anyone here have any experience swapping a commodore LS1 to LS3? Did you use the LS3 bolt-ons or somehow make the LS1s fit?

Any advice appreciated.
Cheers!
 

Freedon

Member
Joined
Apr 9, 2012
Messages
250
Reaction score
16
Points
18
Location
queensland
Members Ride
vu ss
you'll need to use the ls1's balancer and use ls1 waterpump ,modify the rear of the ls1's waterpump ( bolts hit timing cover )
 

NickGNB

New Member
Joined
Aug 31, 2014
Messages
29
Reaction score
0
Points
1
Location
Sydney-North Shore
Members Ride
VY SS Sedan, VY II Acclaim Wagon, Ford Territory
Cheers mate. Anything to know about swapping the balancer? You wouldn't happen to have any specific information on modifying the waterpump would you?

Also do you know if there are any issues with the P/S pump outlet fowling the first plug lead?

Cheers
 

Freedon

Member
Joined
Apr 9, 2012
Messages
250
Reaction score
16
Points
18
Location
queensland
Members Ride
vu ss
basically you replace the bolts on the back with countersunk bolts ( 6mm from memory )

heres a pic of it



i did have a build thread on here, but seems to have disappeared with the forum upgrade

i cant recall having an issue with power steering pump
 

NickGNB

New Member
Joined
Aug 31, 2014
Messages
29
Reaction score
0
Points
1
Location
Sydney-North Shore
Members Ride
VY SS Sedan, VY II Acclaim Wagon, Ford Territory
Cheers mate, Might get myself a new LS1 pump and then fit that. Any opinions on throttle bodies? Did you use the LS1 with an adaptor plate or swap to something else?

Cheers
 

Freedon

Member
Joined
Apr 9, 2012
Messages
250
Reaction score
16
Points
18
Location
queensland
Members Ride
vu ss
originally used a edelbrock 4 bolt cable one, picked up a fast manifold cheap and got amatching 100mm fast throttlebody on it atm.
ive heard holleys can be a bit flaky and was recommended the edelbrock one, never had any issues with it. avoid proflow ones, if your looking for a bracket to suit oem manifold, summit racing sell them. if your prepared to spend some extra cash the edelbrock waterpump is good and will last longer than a oem style one. belt tentioner, get a aeroflow one , but use a oem pully( their weak point ).
 
Top