Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vs hsv manta tps problem

Discussion in 'VR - VS Holden Commodore (1993 - 1997)' started by Mihai, Apr 21, 2019.

  1. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    Hello I have a problem with my iac it's new but when I disconnect it car runs good when I plug it in rev the car end the rev sticks a 1500 then drops back slowly if I can get a bit of help with this problem thanks
     
    Last edited: Apr 21, 2019
  2. Wozza

    Wozza Well-Known Member

    Messages:
    1,888
    Likes Received:
    284
    Trophy Points:
    83
    Joined:
    Dec 13, 2011
    Location:
    Adelaide
    Members Ride:
    VR_GS commodore
    did you replaced the part in circled in the pic, sometimes it falls out or gets stuck in old tps when replacing the tps
    adaptor.jpg
     
    Mihai likes this.
  3. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    No I did no mate did my new one have one on it ?
     
  4. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    Sorry mate I meant my ica is playing up coz when I disconnect it car runs good if it's connected end I give it a hard rev the rev go's up to 1500 then slow to drop back to normal if not connected its won't do it
     
  5. Wozza

    Wozza Well-Known Member

    Messages:
    1,888
    Likes Received:
    284
    Trophy Points:
    83
    Joined:
    Dec 13, 2011
    Location:
    Adelaide
    Members Ride:
    VR_GS commodore
    IAC? if so maybe a air leak.... do a search on here as Ive seen post re this before, just cant find em :)
     
    Mihai likes this.
  6. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    Ok mate I will thanks
     
  7. delcowizzid

    delcowizzid on holiday

    Messages:
    6,892
    Likes Received:
    367
    Trophy Points:
    83
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    It will be programmed in the tune to add iac steps when you stab the throttle and then remove them slowly. If it seems to high before dropping back it may have the wrong size iac tip or pintle to use the proper name there's 2 sizes of hole in ecotec throttlebodies and 2 sizes of pintles if it has the wrong one it could let in too much air for the programmed number of steps and cause high rpm and slower recovery
     
  8. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    is a 304 v8
     
  9. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    When I take the plug out it runs good won't have that problem
     
  10. Deuce

    Deuce Super Stock

    Messages:
    2,236
    Likes Received:
    661
    Trophy Points:
    113
    Joined:
    Feb 5, 2012
    Location:
    Meremere Dragway (as often as possible)
    Members Ride:
    '94 VR SS V8
    Have you adjusted the throttle stop? Maybe that's thrown the figures out and ecu is compensating poorly
     
  11. Mihai

    Mihai Member

    Messages:
    38
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Dec 19, 2018
    Location:
    Sydney
    Members Ride:
    Vs hsv manta
    No I did not mate wher is that at?
     

Share This Page