Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VE SS Wagon 12" sub install... with photos...

joh040

New Member
Joined
Feb 12, 2011
Messages
7
Reaction score
0
Points
1
Age
37
Location
Shepparton
Members Ride
nil
Pretty happy with the way this turned out in our 2009 VE SS Wagon:




Bayside Auto Styling 12" sub enclosure $328 delivered

Pioneer Amplifier - 2 Channel 500 Watts (bridgeable), GMA3702 1 X 190 Watts RMS $143

Alpine W12S4 Bass Series 12" Single Subwoofer 250 Watts RMS $119




The install was reasonably straight forward as we are running the Aerpro aftermarket fascia & a Pioneer touch screen, sub our RCA and bridged the amp for the sub. I'm really impressed with the efficiency of this sub, whether it’s the fact its installed in a wagon or the enclosure itself...




It's hits harder than previous dual 12" we’ve had in the past!




I may yet tidy up the cabling some more, but overall happy with the install.
 

Attachments

Subju

Active Member
Joined
Feb 10, 2018
Messages
712
Reaction score
247
Points
43
Location
Sydney
Members Ride
VE Clubsport Tourer
I like that, how much for all the bits. I have a huge box in the back and it takes up so much room. Would kill for something more compact like that. Can you put the seats down still?

How have you found that Alpine system? Does it always connect?

Any problems with the air con afterwards, having issues with mine. I have the 702d.
 
Top