Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VE 2007 (Series 1) CD player "Disk Error" message on start of car

gjtucker

New Member
Joined
Feb 2, 2014
Messages
12
Reaction score
0
Points
0
Location
Perth
Members Ride
VE Lumina 07
Hey all,

For the past couple weeks every so often when I start the car, after a couple minutes a message comes up on the middle display between the a/c vents, 'DISK ERROR' followed by a beep and the cd player sounds like it's trying to eject a disk however I don't have a disk in the player. Sometimes following that message another one will appear accompanied with a loud beep saying, 'MECHANISM ERROR'. I just went to start the car now so I could take a couple snaps on my phone but nothing happened.

Has anyone else come across this, and if so how was it fixed?

Cheers!
 

hotrod

Banned
Joined
Jul 21, 2013
Messages
1,152
Reaction score
7
Points
0
Location
victoria
Members Ride
commodore s2
ghost in the unit.
 

Muke

Member
Joined
Sep 11, 2011
Messages
532
Reaction score
6
Points
18
Location
Brisbane
Members Ride
VE SV6 MY08
Whilst having a yarn to a VE/VF commodore wrecker, he was saying that you can just swap the CD mechanism over from another unit. That is, find the cheapest VE headunit you can and remove the CD part and swap them over. (I haven't done this). If you swap the whole headunit, you'll need to have it programmed either with a Tech2 or with an eeprom programmer (easy if you have one - just swapping the VIN in the code), but apparently just swapping the CD mechanism works with nothing else needed. If it's the same model headunit, but a different colour (like between Omega and SV6 Series 1) you can keep your faceplate, but will need to use an eeprom programmer on it to match the main unit's matching code. (Done the eeprom thing a few times on both whole unit and faceplate - it definitely works).
As for trying to fix the one you've got, I haven't attempted that. But if you're confident (or figure it is broken and can't break it more), you could just pull it apart and see if there's something obvious (like something jammed in there).
 

Veberlina

Member
Joined
Aug 1, 2013
Messages
85
Reaction score
0
Points
6
Age
36
Location
Perth
Members Ride
ve berlina
Had exact problem in a WM Bose headunit i put in my berlina.

Generally means The cd player unit is broken. As above poster said buy a cheap headunit from a berlina etc and swap the cd unit out, it just unscrews from the main unit. Any unit will swap in without any progging required.

Note this can rarely also mean the main box is stuffed in which case u need a whole new headunit box. The first bose unit i bought had same problem and only changing the box fixed it.
 

bigdaddycool

Member
Joined
Sep 5, 2008
Messages
500
Reaction score
9
Points
18
Location
Brisbane, Queensland
Members Ride
2009 VE SS SILVER SEDAN
Hey all,

For the past couple weeks every so often when I start the car, after a couple minutes a message comes up on the middle display between the a/c vents, 'DISK ERROR' followed by a beep and the cd player sounds like it's trying to eject a disk however I don't have a disk in the player. Sometimes following that message another one will appear accompanied with a loud beep saying, 'MECHANISM ERROR'. I just went to start the car now so I could take a couple snaps on my phone but nothing happened.

Has anyone else come across this, and if so how was it fixed?

Cheers!
Just unplug the damn thing and plug it back in........ See if that helps..... honestly mine did some weird crap and that what i did and it was good as gold, either that or its stuffed and or you have kids and they've been depositing money to your cd player :)
 
Top