Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

High Fuel Consumption

Discussion in 'VT - VX Holden Commodore (1997 - 2002)' started by DeathSammich, Aug 7, 2017.

  1. DeathSammich

    DeathSammich Member

    Messages:
    97
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Jun 27, 2017
    Location:
    Hobart, Tasmania
    Members Ride:
    VT Berlina S1
    Sorry for posting again but my VT is using a lot of fuel, 15L per 100KM. I've recently changed the fuel pump, o2 Sensors, fuel filter, oil, oil filter, cleaned maf sensor and changed air filter and still it uses heaps of fuel. What else can I do to fix this issue?
     
  2. NeddyBear

    NeddyBear Veteran Mountain Biker

    Messages:
    1,476
    Likes Received:
    182
    Trophy Points:
    63
    Joined:
    May 5, 2011
    Location:
    Queensland
    Members Ride:
    2004 Subaru Outback 2.5 & 2002 VX II Acclaim
    Did it go from using the normal amount to the 15L/100 over a short period or over a lengthy period.
    How's the sensors and all things fuel related and also how many ks has she done.
     
  3. DeathSammich

    DeathSammich Member

    Messages:
    97
    Likes Received:
    1
    Trophy Points:
    8
    Joined:
    Jun 27, 2017
    Location:
    Hobart, Tasmania
    Members Ride:
    VT Berlina S1
    When I first got it it read 12.8 per 100 but the guy I got it off lived in an area where it was always long drives. When I got it it just began to get higher and higher. After unplugging the battery it never goes below 14.2 and just goes up and down from there. It has 280xxx kms
     

Share This Page