Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Changed ECM, BCM and pim but no start

Discussion in 'Electrical Wiring / Questions' started by Zachg, Sep 7, 2019.

  1. Zachg

    Zachg New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Sep 7, 2019
    Location:
    Townsville
    Members Ride:
    Vz sv6
    Hey guy, so I have a vz sv6 that had a no crank issue and only working once we jumped the starter relay that we later found out it was a bad BCM. I found out that we could replace ECM BCM and pim with a matching key and it should all be plug and play. At the moment it is just cranking but doesn't turn over. Does anyone have any suggestions on what could be happening. Also no code when we plug a scan tool in.
     
  2. Trevor loves holden.

    Trevor loves holden. Well-Known Member

    Messages:
    2,345
    Likes Received:
    420
    Trophy Points:
    83
    Joined:
    Jun 6, 2019
    Location:
    Victoria
    Members Ride:
    vs commodore
    The ECU and BCM you replaced was it a carbon copy of your original number on yours.
     
    Zachg likes this.
  3. Zachg

    Zachg New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Sep 7, 2019
    Location:
    Townsville
    Members Ride:
    Vz sv6
    If you are referring to the numbers on the compliance plate then yes I made sure I got the right one, Mine was a LY7 and the one I got matched it. Would there have to be some reprogramming involved?
     
  4. delcowizzid

    delcowizzid on holiday

    Messages:
    6,891
    Likes Received:
    361
    Trophy Points:
    83
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    Did you change the key head too
     
  5. Zachg

    Zachg New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Sep 7, 2019
    Location:
    Townsville
    Members Ride:
    Vz sv6
    I sure did
     
  6. Trevor loves holden.

    Trevor loves holden. Well-Known Member

    Messages:
    2,345
    Likes Received:
    420
    Trophy Points:
    83
    Joined:
    Jun 6, 2019
    Location:
    Victoria
    Members Ride:
    vs commodore
    Well then it should work, are you getting spark and fuel? engine getting good earth? Is the light out on the dash before starting? Is your bcm and ecu getting good earth? Are the fuses and relays good, those big fuses in the engine bay.
     
  7. Zachg

    Zachg New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Sep 7, 2019
    Location:
    Townsville
    Members Ride:
    Vz sv6
    All the fuses are brand new as well as the relays and got a good cleaning when we replaced them. I have a funny feeling I might have got sold the wrong items but I will go over and check the earths to make sure.
     

Share This Page