Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

help plz

  1. B

    VT S2 commodore under powered

    Hi. I have a VT series 2 that feels under powered FULL STORE The car was passed down to me in 2011 from my dad who made a mistake and bought a ford. The car's engine blew in 2010 and my parents really wanted me to have the car so they got keven dennis holden to install a totally new...
  2. L

    Oil leak from Oil Pressure Sensor

    Hey all, I'm hoping someone might be able to help me, my '04 VX has just started pissing oil from the oil pressure sensor. It's had a slight leak for a while, but today it completely fubar'd. Any tips on changing it? Do I need to replace to whole thing that screws into the engine? Or will...
  3. jayden.2.2

    VE Berlina stereo specs

    Hey guys, Could anybody please help me out with the specs of the stock stereo system fitted in the ve berlina? Everything from head unit specs to speaker specs would be very greatly appreciated. Thanks lads.
  4. V

    need info on Vl V8 ignition fuse blows under acceleration

    Hey guys, Just wondering if anyone can give me some advice on what my gremlin might be on my Vl 5.0L. Every time I accelerate in my car it blows out the ignition fuse and after having it off the road for a month waiting for a rebuilt Quady i finally get it going it idled away for...
  5. O

    Carby Backfire and Valve timing - Need Help!

    Hey All, First I'd like to say that I love this site; and the vast majority of the time I find all the info I need on existing posts and help where I can. But this time I'm in dire need of a complicated problem. I have an 85' VK commo, black 202 6 cyl. I have Scraped the EST and am...
  6. V

    VT clunking noise

    hi just spent about 2500 on all this **** and it didnt even fix the noise im getting when i drive slow and turn or go up a gutter i replaced the sway bar link, upper and lower control arm bushes, new shocks, new strut top bearrings and still getting the clunking noise could it be my gearbox...
Top