Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

ground

  1. B

    VT SS blowing main fuse (SOLVED)

    Hi i bought a vt ss a few days ago and everything was fine untill yesterday i went to start the car and and all power went out, checked fuses and the main fuse (60amp) has blown, replaced with another and tried again, blew once more. Not sure whats cauing this to happen but cant drive the car...
  2. B

    VT headlights dim

    Hi, was wondering if anyone could offer any advice? After driving through *almost* flood water on my way to work, I noticed that the driver's side headlight had stopped working. Swapped it with passenger side, and they both worked, but very dim. Found ground near back of battery and cleaned, but...
  3. BigBoss

    Ground loop headache!!

    Hey all, I have a VE omega with a carputer setup i love it but... i am getting a ground loop hiss over my AUX in i am utilising the rear input in my head unit and still getting it. I am using a usb audio device and a quality cable connecting the two. any suggestions?
  4. vscom88

    installed 2 amps but no power?

    Hey, i just replaced my 4ch pioneer amp after all but 1 channel mysteriously went while re wiring everything. i replaced it with a 4ch kenwood amp, i have wired up all 4 speakers to there channels, done the remote, ground and power wire and now neither amps are getting power?\ i had a spare...
Top